系统要求:COMSOL Multiphysics®版本5.6

这些要求对所有平台都是常见的:

  • 安装期间建议使用工作网卡和互联网连接
  • 建议至少4 GB的RAM
  • 2-13 GB的磁盘空间,具体取决于您的许可产品和安装选项乐动体育app无法登录
  • adobe.®杂技演员®阅读器以PDF格式查看和打印COMSOL文档
  • 英特尔®或amd.®基于英特尔的64位处理器®64或AMD64架构与SSE4指令集。英特尔®处理器2009年或更高版本和AMD发布®2012年或以后发布的处理器满足此要求。

有关硬件的进一步建议,请查看我们的知识库入口

操作系统要求

除了下面列出的操作系统要求外,请参阅接口产品套件要求有关CAD导入模块,设计模块和Livelink™产品的特定要求。乐动体育app无法登录COMSOL Compiler™的系统要求与COMSOL Multiphysics的系统要求相同®

视窗® 苹果系统 Linux.®
64位操作系统
  • 视窗®10.
  • 视窗®10 Pro for Workstations
  • 视窗®8.1
  • 视窗®7 SP1
  • Windows服务器®2019年
  • Windows服务器®2016年
  • Windows服务器®2012年R2
  • Windows服务器®2012年
  • Windows服务器®2008 R2 SP1
  • Windows HPC Server 2008 R2 SP1
MacOS 10.13,10.14,10.15和11.0
  • debian.®9和10
  • 红帽®企业Linux®7.8和8.2
  • CentOS 7.8和8.2
  • 甲骨文®Linux.®8.2
  • Ubuntu.®16.04,18.04和20.04
  • SUSE.®Linux EnterpriseDesktop®15SP2
  • opensuse.®LEAP 15.1和15.2

特定于操作系统的系统要求

Linux.®
  • GNU C库2.17或更高版本
  • Linux.®内核3.10或更高版本
  • Flexnet.®许可证管理器需要Linux标准基础(LSB™)1

1请参阅Flexnet.®Linux上的许可证管理器®以下。

Linux上的帮助系统®

为了让帮助系统在Linux上工作®操作系统,需要安装以下包:

操作系统 包裹名字
debian.®9和10. libwebkit2gtk-4.0-37
Ubuntu.®16.04,18.04和20.04 libwebkit2gtk-4.0-37
红帽®企业Linux®7和CentOS®7 WebKitgtk4.
红帽®企业Linux®8,CentOS®8和甲骨文®Linux 8. webkit2gtk3.
SUSE.®Linux EnterpriseDesktop®15SP2 libwebkit2gtk-4_0-37
opensuse.®LEAP 15.1和15.2 libwebkit2gtk-4_0-37

Flexnet.®许可证经理

许可证管理器的系统要求与COMSOL Multiphysics相同®。除了Linux®系统要求,许可证管理器支持Red Hat®企业Linux®6,SUSE.®Linux EnterpriseDesktop®11.4和Debian®6和更晚。Flexnet.®版本11.16.2.1用于所有平台。版本lmgrd.必须与FlexNet相同或更高®COMSOL使用的版本®软件。

Flexnet.®Linux上的许可证管理器®

Linux需要Linux标准基础(LSB™)®在许可证服务器计算机上。

如果分发存储库中缺少LSB™核心包,请手动创建索引的符号链接:

ln -s /llib64/ld-linux-x86-64.so.so 2.2 /lib64/ld-lsb-x86-64.so.3

分配 需要包裹
debian.® LSB核心
Ubuntu.® LSB核心
红帽® redhat-lsb.
SUSE.® LSB.

应用程序建设者

Windows中支持Application Builder®操作系统。

Microsoft加载项®微软幻灯片软件®

PowerPoint的COMSOL加载项®与PowerPoint兼容®2010年,2013年,2016年和2019年在窗户上®操作系统。微软幻灯片软件®2010年起动器不受支持。如果您使用的是Office 365,PowerPoint®必须安装在计算机上 - 加载项需要一个版本的PowerPoint®支持vsto加载项。

并行系统要求

视窗® 苹果系统 Linux.®
共享内存并行性 所有支持的Windows版本® 所有支持的麦斯卡斯版本 所有支持的Linux®分布
分布式内存并行性
  • Windows服务器®2019年1
  • Windows服务器®2016年1
  • Windows服务器®2012年R21
  • Windows服务器®2012年1
  • Windows HPC Server 2008 R2 SP1
不支持
  • 红帽®企业Linux®7.8
  • CentOS 7.8.
  • debian.®9.
  • Ubuntu.®16.04和18.04

群集中的所有计算机必须使用相同的Linux®版本,应该有类似的硬件。建议安装开放式企业分发(以1.5.4.1或更高版本安装。如果您使用的是使用RDMA的网络结构,则需要DAPL 1.2或更高版本符合版本的驱动程序或库。该软件通常提供您的硬件。

1需要用于相应Windows服务器版本的Windows HPC包。

有关如何运行COMSOL Multiphysics的信息®和COMSOL Server™在云中,请查看此页面

正式支持的编制者

COMSOL Multiphysics.®为应用程序构建器中的外部功能,外部材料和外部C库提供外部C接口。

视窗® 苹果系统 Linux.®
外部C接口 Microsoft Visual Studio®2017年 英特尔®Parallet Studio XE Composer Edition for C ++ MacOS 18.5(也称为英特尔®C ++编译器版本18.0.6)与Apple LLVM版本9.1.0(Clang-902.0.39.2)正式支持 英特尔®Partinal Studio XE Composer Edition for C ++ Linux®18.4(也称为英特尔®C ++编译器版本为18.0.5)与GCC 6.5.0正式支持
java.®API. JDK 1.7和1.8 JDK 1.7或1.8 JDK 1.7和1.8

COMSOL Multiphysics.®使用上述C / C ++编译器进行建立和测试。请注意,稍后版本的C / C ++编译器也可以与外部C接口兼容。使用COMSOL API与Jav​​a一起使用时®客户端/服务器模式中的API与<安装dir> /bin/comsolclientpath.txt中列出的jar文件,支持JRE 1.7和JRE 1.8。使用COMSOL API与Jav​​a一起使用时®独立模式下的API与<安装dir> /bin/comsolpath.txt中列出的jar文件,支持JRE 1.8。

图形系统要求

COMSOL建议出于性能原因的硬件渲染。硬件呈现需要支持OpenGL的驱动程序®版本2.0。视窗®操作系统用户也可以使用DirectX®本地控制台上的版本9。硬件渲染需要至少24位颜色图形。

优化质量图形首选项中的设置需要OpenGL®2.1。软件渲染也支持16位颜色图形。出于性能原因,我们建议图形卡具有至少512 MB的内存。

amd.®

视窗®10.

卡模型 驱动程序版本
AMD Radeon™Pro VII 20.Q3.
AMD Radeon™Pro WX 9100 20.Q3.
AMD Radeon™Pro WX 8200 20.Q3.
AMD Radeon™Pro WX 7100 20.Q3.
AMD Radeon™Pro WX 5100 20.Q3.
AMD Radeon™Pro WX 4100 20.Q3.
AMD Radeon™Pro WX 3200 20.Q3.
AMD Radeon™Pro WX 3100 20.Q3.
AMD Radeon™Pro WX 2100 20.Q3.

Ubuntu.®20.04

卡模型 驱动程序版本
AMD Radeon™Pro WX 9100 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 8200 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 7100 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 5100 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 4100 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 3200 AmdGPU(Linux.®5.4)
AMD Radeon™Pro WX 2100 AmdGPU(Linux.®5.4)

Ubuntu.®18.04

卡模型 驱动程序版本
AMD Radeon™Pro WX 3100 AmdGPU(Linux.®5.4)

nvidia.®

视窗®10.

卡模型 驱动程序版本
Quadro.®RTX 3000. 452.06
Quadro.®T1000. 452.06
Quadro.®P4000. 452.06
Quadro.®P3200. 452.06
Quadro.®P2000. 452.06
Quadro.®P1000. 452.06
Quadro.®P600. 452.06

视窗®7.

卡模型 驱动程序版本
Quadro.®P400. 452.06

上面列出的图形卡已经严格地测试了与COMSOL Multiphysics的兼容性®软件。但请注意,其他AMD®或nvidia®显卡也可能与COMSOL Multiphysics兼容®。属于与上面列出的卡片之一,属于与上述卡片相同的型号的显卡更有可能与COMSOL Multiphysics兼容®

用于Linux上的硬件加速®,请使用从您的显卡供应商(如NVIDIA)的专有驱动程序®;否则,使用comsol®软件渲染。Nouveau视频驱动程序仅支持软件渲染。

注意:此信息是为您的利益提供的,但不应用作您对您自己调查的替代品,这些系统要求可能适合您使用COMSOL®鉴于您的特定情况,软件或其他软件。系统和硬件定期更改,这可能会影响任何系统要求适合您的确定。

Adobe和Acrobat是在美国和/或其他国家/地区的Adobe系统注册商标或商标。AMD,AMD Athlon,Firepro和Radeon是Advanced Micro Devices的商标或注册商标,Inc。Debian是在美国公共利益的软件的注册商标。FlexNet是Flexera Software LLC的注册商标。NVIDIA和NVIDIA Quadro是美国和/或其他国家的NVIDIA CORPORATION的注册商标。英特尔和奔腾是英特尔公司的商标或美国和/或其他国家的子公司。Oracle和Java是Oracle和/或其关联公司的注册商标。Red Hat,Red Hat Enterprise Linux和CentOS是Red Hat,Inc。Ubuntu的注册商标,是典范有限公司的注册商标。Opengl是Silicon Graphics,Inc。的商标或注册商标,在美国和/或其他国家/地区全世界。OpenSUSE和SUSE是SUSE LLC的注册商标。Linux,Linux标准基础和LSB是美国和其他国家的Linus Torvalds的商标或注册商标。 macOS is a trademark of Apple Inc., in the U.S. and other countries. Microsoft, DirectX, PowerPoint, Visual Studio, Windows, and Windows Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. COMSOL AB and its subsidiaries and products are not affiliated with, endorsed by, sponsored by, or supported by these trademark owners.